CVE-2022-43719GHSA-7222-R37X-8Q3MBIT-SUPERSET-2022-43719PYSEC-2026-775
Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.1, 1.5.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Two legacy REST API endpoints for approval and request access are vulnerable to cross site request forgery. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Apache Software Foundation Apache Superset
From 2.0.0 · fixed in 2.0.1; through 1.5.2
- apache-supersetPyPI
through 1.5.2
- apache-supersetPyPI
2.0.0
- apache-supersetPyPI
fixed in 1.5.3; From 2.0.0 · fixed in 2.0.1