Skip to main content
← All vulnerabilities
CVE-2022-43718PYSEC-2026-777BIT-SUPERSET-2022-43718GHSA-79X5-CV79-49RJ

Apache Superset: Cross-Site Scripting vulnerability on upload forms

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 2.0.1, 1.5.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Superset

    From 2.0.0 · fixed in 2.0.1; through 1.5.2

  • apache-supersetPyPI

    fixed in 1.5.3; From 2.0.0 · fixed in 2.0.1

  • apache-supersetPyPI

    through 1.5.2

  • apache-supersetPyPI

    2.0.0

References 1

lists.apache.org