Skip to main content
← All vulnerabilities
CVE-2022-42119GHSA-WJFM-QXG2-Q679

Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.8, 7.3.10.u8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Certain Liferay products are vulnerable to Cross Site Scripting (XSS) via the Commerce module. This affects Liferay Portal 7.3.5 through 7.4.2 and Liferay DXP 7.3 before update 8.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • com.liferay.commerce:com.liferay.commerce.catalog.webMaven

    fixed in 4.0.8

  • com.liferay.portal:release.dxp.bomMaven

    From 7.3.0 · fixed in 7.3.10.u8

References 2

portal.liferay.dev

issues.liferay.com