Skip to main content
← All vulnerabilities
CVE-2022-4131

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.8 before 15.5.7, all versions starting from 15.6 before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.5.7, 15.6.4, 15.7.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.8 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. An attacker may cause Denial of Service on a GitLab instance by exploiting a regex issue in how the application parses user agents.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 10.8 · fixed in 15.5.7; From 15.6 · fixed in 15.6.4; From 15.7 · fixed in 15.7.2

References 3

gitlab.com

hackerone.com