Skip to main content
← All vulnerabilities
CVE-2022-4064GHSA-3XG8-CC8F-9WV2

Dalli Meta Protocol request_formatter.rb self.meta_set injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a Dalli

    3.2.0, 3.2.1, 3.2.2

  • dalliRubyGems

    fixed in 3.2.3

References 7

vuldb.com

GitHub · petergoldstein/dalli

GitHub Advisory Database